Home

   Home

   Download


Help

   FAQ

   Installation

   Message Board

   Importing Data File
   Into GoldMine
   Into Act


Other

   Testimonies

   Custom Programming

   PHP Version


Other Favorites

   Hire a clean comedian

   Bible Search Engine

   Bible in a Year

   Parallel Bible

   The Richer Life










 





[ Message Board Home ]    [ Post Reply ]    [ Log In ]    [ Sign Up ]



  Subject: error page problems
  Posted: 03/01/2004 at 4:50:42 pm
  By: Timah

Hi Seth, first a big thank you for this great script. I'm hoping you can help me get it to work. I keep getting the blue box error page and I can't figure out why. I want to use this script as a way to email my customers a confirmation copy of their order, so I have it set up in the same form as my checkout page. Will that be possible? Here's the link to my shopping cart where you can add products to it and then click on checkout http://www.sweetbasilcards.com/cart.html

My web host had me put scripts in a folder called "cgi" and he changed the CHMOD to 705 to get other scripts to work. They wouldn't work when they were 755. Is it normal to have the group permissions mess things up? and could I have other files CHMODed wrong? I even tried turning off the writing to the .dat file to see if that helped. Please help, I'm almost there!

Thanks again,
Tim



  Subject: Re: error page problems
  Posted: 03/01/2004 at 8:12:12 pm
  By: Seth Knorr

Yes you have everything setup correctly. The only problem is that you are not posting to the script. Instead you are using the GET method, this is why your are having problems.

If you would like to make it work open bizmail.cgi and go to line: 235

You should see:
if($ENV{'REQUEST_METHOD'} eq "GET") {

YOU WOULD HAVE TO CHANGE THIS TO:
if($ENV{'REQUEST_METHOD'} eq "POST") {

for the script to work the way you want it. It is not highly recommended though. I would just try to set it up where you then post once more to after the successfull check out to the bizmail.cgi

Seth



  Subject: Re: error page problems
  Posted: 03/02/2004 at 7:30:24 am
  By: Timah

Seth,
Well I got it to stop going to the error screen, but now I just get the 500 internal error. I emailed my host to see what he thought was the problem and he couldn't figure it out. Could my host not support that "POST" method? I'm confused about your last sentence too, what do you recommend I do, post once more?
Thanks,
Tim



Reply To This Topic

Subject
Message  
Username
Password
Due to unrelated post's, you must have an
account to post a message. To Sign Up click here.




Copyright 2000-2010 Seth M. Knorr,
BizMailForm.com Forms Processor, All Rights Reserved