Home

   Home

   Download


Help

   FAQ

   Installation

   Message Board

   Importing Data File
   Into GoldMine
   Into Act


Other

   Testimonies

   Custom Programming

   PHP Version


Other Favorites

   Hire a clean comedian

   Bible Search Engine

   Bible in a Year

   Parallel Bible

   The Richer Life










 





[ Message Board Home ]    [ Post Reply ]    [ Log In ]    [ Sign Up ]



  Subject: Success Form, but no email or data file
  Posted: 08/02/2004 at 6:04:04 pm
  By: himsati

Hello,

It looks like you have a wonderful script and I've downloaded the Windows version to use at a secure site with our hosting provider as follows:
Form-Page - https://www.readysecure4.com/users/essiac-canadacom/order.htm

Script -https://www.readysecure4.com/users/essiac-canadacom/cgi-bin/bizmail.pl

The permissions for every single file are set to 777. I've got an orderlog.dat file in both the cgi-bin and in the main directory and have tried both (tried accessing by just the orderlog.dat and then by using the full URL to both the one in the cgi-bin and in the main directory. I've got the smtp ip address to use for the server per the ISP, and I've put it in the script, and I've even turned off URL checking (though I did put in the URL for the main site (www.essiac-canada.com), the provider's main site (readyhosting.com), the secure server and the smtp ip address as all legitimate. I get the success page (not using the success script, just having it go to the success page we already setup), but no email goes out to me, to the purchaser, and nothing goes to the datafile. Any help would be appreciated, because I'd like to use this in a few places and credit your work on the form itself each time. My boss thinks if we can work out the kinks than we have the perfect script for one-shot forms to use with this particular ISP.



  Subject: Re: Success Form, but no email or data file
  Posted: 08/02/2004 at 6:29:37 pm
  By: himsati

Just as an add-on, here is the initial information we received when we setup the SSL site from the provider, I then emailed and asked for the smtp server address to use which they gave me:
Login to this account. You will need the following before your site will
work.

1. Your form.
2. A mailto script.
3. A confirmation page. This is the page that the customer sees AFTER they
submit your form.
4. Any graphics that go on these pages.

Upload the previous 4 items into the directory that you logged into.
Reference your order/form page with the following URL:
https://www.readysecure4.com/users/essiac-canadacom/(form/order).htm
All graphics and scripting must be referenced with this entire URL in order
for your secure form to work.

If you need the physical path to your secure space, it is
d:\html\users\readysecure4com\users\essiac-canadacom



  Subject: Re: Success Form, but no email or data file
  Posted: 08/03/2004 at 1:13:53 pm
  By: Seth Knorr

It looks like the problem is your server is not setup to where it can open files and then repost them. As the error page is not showing up properly. bizmail.pl (in your case) when it pulls up the error page, opens error.html, gathers the information out of it, and then posts the information. However the problem is that the script is UNABLE to open error.html. You may need to make this script 777 or READ-WRITE-EXECUTABLE for all. Or check with your host on the problem.

Also, are you using the windows version of the script.

Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/04/2004 at 9:57:42 am
  By: himsati

Yes, using the windows version of the script, and I've changed permissions on all files read as 777 (every single file) when I go in and look at them, is it possible that the files may be saying they are 777 but in reality for some reason are not?



  Subject: Re: Success Form, but no email or data file
  Posted: 08/04/2004 at 10:00:20 am
  By: himsati

Had another thought, would there be any place in your script concerning the location of files (like orderlog.dat) that I would need to reference by physical path instead of url?



  Subject: Re: Success Form, but no email or data file
  Posted: 08/04/2004 at 11:00:27 am
  By: Seth Knorr

There are two files you can try to put the ABSOLUTE PATH to the files.

$datafile{"1"} = "bizmail.dat";
$MY_error_page = "error.html";

So if your absolute path on the server is:
C:\\home\pages\cgi-bin\

Then it should look like this:


$datafile{"1"} = "C:\\home\pages\cgi-bin\bizmail.dat";
$MY_error_page = "C:\\home\pages\cgi-bin\error.html";

That may be the problem you are running into.

Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/05/2004 at 7:35:56 pm
  By: himsati

Tried it... no go unfortunately. If it wasn't for the fact that we have about 10 domains hosted by this group I'd love to move over to a non-Windows server...... Any other thoughts? I think it might be the ISP, but have no idea what to tell them to check on, and in a way that won't get the "we don't do tech-support on your cgi scripts" line, so they understand that I need them to check the server setup and settings.



  Subject: Re: Success Form, but no email or data file
  Posted: 08/05/2004 at 9:09:18 pm
  By: Seth Knorr

It is hard to say at this point without actually testing your cgi capabilities on the server.

Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/06/2004 at 4:37:31 pm
  By: himsati

Then if you could, I sent off a private email Wed. email in response to what you sent me, if interested, please respond back on that private email then.



  Subject: Re: Success Form, but no email or data file
  Posted: 08/06/2004 at 6:25:30 pm
  By: Seth Knorr

I had sent you an email reply, if you need me to send it again, i will.


Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/10/2004 at 11:49:24 am
  By: bubu678

I am using the same host (ReadyHosting) and am having a similar problem. I do get the data file filled, but am not getting the email sent. I think I did everything correctly (since I am using windows version have deleted first line of code (pointing to path of PERL) as per ISP; added SMTP IP address as per ISP ).



  Subject: Re: Success Form, but no email or data file
  Posted: 08/10/2004 at 12:49:11 pm
  By: himsati

Hey bubu678!

What format did you use in relation to your error and success pages? I get "Location: https://...." it prints the actual field value from the form instead of the actual page. It also does the same thing, writes the data but not the email. Which server are you on? I've tried on both readysecure3 and readysecure4 with varying results but no total successes yet.



  Subject: Re: Success Form, but no email or data file
  Posted: 08/10/2004 at 1:03:23 pm
  By: Seth Knorr

bubu678, As stated on previous posts. It seems to be a hosting issue.

It is really hard to tell what is wrong with out either a server error log, or actualy runing tests at this point.

Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/10/2004 at 1:32:15 pm
  By: bubu678

Thank you for both responses!
himsati: I am on a regular server (ie non SSL) for now. Also are you located in Canada or in Florida (as per your site & domain registration)?

Seth: nice code; would you have any simple test script that could connect to the mail server and send a test e-mail email? I could use it to send to support so they can tell me what is wrong? Only parameter needed to enter is the IP address and sent_to address. The only code sample with this ISP is ColdFusion script. I will try to see if they have a server error log.

Boris



  Subject: Re: Success Form, but no email or data file
  Posted: 08/10/2004 at 2:17:43 pm
  By: Seth Knorr

One other thought, you may want to try to add a "-w" after the path to perl in bizmail.cgi

So if the path to perl is:
/usr/bin/perl

Then use:
#!/usr/bin/perl -w


See if that works for you.

Seth



  Subject: Re: Success Form, but no email or data file
  Posted: 08/11/2004 at 12:44:07 pm
  By: bubu678

The host provider says that the first row is not required. Tried it anyway, but same results. ISP couldn't (or brushed me off) provide any error log (does the script produce any if cannot connect/send?). Since I have devoted too much time on this one I tried some other SMTP scripts (one of them gave me a SMTP ERROR msg but no further description) of which none worked. Alas I resorted to ASPMAIL (also supported by the ISP), found some script similar to yours and it worked out. I will keep your script in mind when trying out some other providers.

Thanks



  Subject: Re: Success Form, but no email or data file
  Posted: 08/11/2004 at 1:27:04 pm
  By: Seth Knorr

It could be that your server does not have Net::SMTP installed on the server.

Your other option is you can try downloading and trying the PHP version of the script found at: http://www.formtofile.com/

However to use that you need to have PEAR installed with PHP, which should already be on the server.

Seth



Reply To This Topic

Subject
Message  
Username
Password
Due to unrelated post's, you must have an
account to post a message. To Sign Up click here.




Copyright 2000-2010 Seth M. Knorr,
BizMailForm.com Forms Processor, All Rights Reserved