Home

   Home

   Download


Help

   FAQ

   Installation

   Message Board

   Importing Data File
   Into GoldMine
   Into Act


Other

   Testimonies

   Custom Programming

   PHP Version


Other Favorites

   Hire a clean comedian

   Bible Search Engine

   Bible in a Year

   Parallel Bible

   The Richer Life










 





[ Message Board Home ]    [ Post Reply ]    [ Log In ]    [ Sign Up ]



  Subject: Not Sending Data Email
  Posted: 10/06/2004 at 2:24:53 pm
  By: ianclarke

Hi Seth,

The script is working fine. Have just created a new form which redirects to the success page OK but is not sending the data email. All other forms are working fine.

Can you see what I'm doing wrong. I've been looking at this for ages but can't find the problem!

<form method="post" action="http://www.mydomain.co.uk/cgi-bin/bizmail/bizmail.cgi">
<input type="hidden" name="subject" value="Web Seminar Feedback" />
<input type="hidden" name="send_to" value="1" />
<input type="hidden" name="success_page" value="http://www.mydomain.co.uk/cgi-bin/bizmail/success.cgi?p=15" />
<input type="hidden" name="sort" value="Like,Dislike,Thinking_Differently,Taking_Action,Other1,Recommend,Recommended_Colleagues,Not_Recommend_Colleague,Different_Topics,Description,Rating,Improve1,Most_Valuable,Improve2,Other2" />
<input type="hidden" name="sendreply" value="0" />
<input type="hidden" name="data_format" value="," />
<input type="hidden" name="datafile" value="1" />

As far as I can tell this is identical to the code in forms that are working properly!

Any suggestions gratefully received.

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/06/2004 at 2:39:43 pm
  By: ianclarke

Hi Seth,

Have been reading more posting on the Message Board. 13 of the 15 fields are text areas. Would this make a difference?

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/06/2004 at 6:26:40 pm
  By: Seth Knorr

Is there an html form that I could look at? (URL)


Seth



  Subject: Re: Not Sending Data Email
  Posted: 10/06/2004 at 10:41:50 pm
  By: ianclarke

Hi Seth,

The form is currently at :

http://www.etaconsulting.co.uk/wl/as/web_seminar.html

Thanks.

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/07/2004 at 7:13:30 am
  By: Seth Knorr

It looks like it could be a sendmail problem or SMTP problem on the server. I would check with the hosting company an make sure the path you are using is correct.

Seth



  Subject: Re: Not Sending Data Email
  Posted: 10/07/2004 at 7:53:57 am
  By: ianclarke

Hi Seth,

What's puzzling is that other forms which are using the same bizmail.cgi are working perfectly. Users are being redirected, data emails are arriving and users are receiving autosend emails.

My assumption is that there is something wrong with the form but, from your comment, I assume the form is OK?

Thanks

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/07/2004 at 9:58:33 am
  By: ianclarke

Hi Seth,

I'm still strugging!

Could be something to do with the email field? I don't require the users email address as the submission is anonymous. Can I leave the email field out completely without problems?

Thanks

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/08/2004 at 2:12:07 am
  By: ianclarke

Hi Seth,

Have been doing some testing. Tried it on a different server and still didn't work. Both hosting companies tell me sendmail is working OK.

The following code works:

<form name="form1" method="post" action="../../cgi-bin/bizmail/bizmail.cgi">
<input type="hidden" name="subject" value="Test" />
<input type="hidden" name="send_to" value="1" />
<input type="hidden" name="success_page" value="http://www.etaconsulting.co.uk/cgi-bin/bizmail/success.cgi?p=15" />
<input type="hidden" name="sort" value="email,success_criteria" />
<p class="justify">
<input type="text" name="email" size="50" />
<br /><br />
<input type="text" name="success_criteria" size="100" />
<br /><br />
<input type="submit" value="Submit My Questionnaire" />
</p>
</form>

However, if I leave the email field blank no data is sent.

The following code doesn't work:

<form name="form1" method="post" action="../../cgi-bin/bizmail/bizmail.cgi">
<input type="hidden" name="subject" value="Test" />
<input type="hidden" name="send_to" value="1" />
<input type="hidden" name="success_page" value="http://www.etaconsulting.co.uk/cgi-bin/bizmail/success.cgi?p=15" />
<input type="hidden" name="sort" value="success_criteria" />
<p class="justify">
<input type="text" name="success_criteria" size="100" />
<br /><br />
<input type="submit" value="Submit My Questionnaire" />
</p>
</form>

So it seems that a) if the email field is left blank or b) the email field doesn't exist the data email isn't sent. The user is always redirected to the success page.

How do I create a form that doesn't require the user to give an email address but sends the data email? Any help would be gratefully received as I have now spent many hours on this!

Best wishes

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/08/2004 at 4:21:33 am
  By: ianclarke

Hi Seth,

More research reveals:

1. Setting value = "x" to 0 or 2 in

<input type="hidden" name="send_to" value="x" />

doesn't allow the script to work.

2. Setting value = "x" to 0 or 2 in

<input type="hidden" name="send_to" value="x" />

and adding

<input type="hidden" name="email" value="me@mydomain.com" /> and including "email" in the hidden "sort" field

allows the script to work!

3. Data emails now arrive from me@mydomain.com.

Am I still doing something wrong or is there a bug in the script?

Best wishes

Ian




  Subject: Re: Not Sending Data Email
  Posted: 10/08/2004 at 6:00:41 am
  By: Seth Knorr

Your problem probably has to do with the email address that is receiving the mail. Are they the same on 0 & 2 as on 1. ALSO are the numbers corresponding to the email address.

AND YOU SHOULD BE ABLE TO REMOVE:
<input type="hidden" name="email" value="me@mydomain.com" /> and including "email" in the hidden "sort" field

Seth



  Subject: Re: Not Sending Data Email
  Posted: 10/11/2004 at 3:05:21 am
  By: ianclarke

Hi Seth,

Thanks for your response.

There is only one email address and I've just realised my previous posting was incorrect.

The script that is now working is as follows:

<form method="post" action="http://www.etaconsulting.co.uk/cgi-bin/bizmail/bizmail.cgi">
<input type="hidden" name="subject" value="Web Seminar Feedback" />
<input type="hidden" name="send_to" value="2" />
<input type="hidden" name="success_page" value="http://www.etaconsulting.co.uk/cgi-bin/bizmail/success.cgi?p=15" />
<input type="hidden" name="email" value="me@mydomain.com" />
<input type="hidden" name="sort" value="email,Like,Dislike,Thinking_Differently,Taking_Action,Other1,Recommend,Recommended_Colleagues,Not_Recommend_Colleagues,Different_Topics,Description,Rating,Improve1,Most_Valuable,Improve2,Other2" />

If I remove

<input type="hidden" name="email" value="me@mydomain.com" />

the script no longer works.

I thought I could just leave <input type="hidden" name="email" value="" /> out if I didn't require the user to give his/her email address but leaving it out stops the script working.

Am I still doing something wrong or is there a bug in the script?

Best wishes

Ian



  Subject: Re: Not Sending Data Email
  Posted: 10/11/2004 at 5:27:08 am
  By: Seth Knorr

You are not doing something wrong, it sounds like a server configuration problem, with error reporting. The setting are set to really sensitive, thus they are not working, is a good posibility.

Seth



  Subject: Re: Not Sending Data Email
  Posted: 10/13/2004 at 6:41:26 am
  By: ianclarke

Hi Seth,

Thanks - curious that I had the problem on 2 different servers. At least it's working properly now.

Best wishes

Ian



  Subject: Re: Not Sending Data Email
  Posted: 11/04/2004 at 7:23:00 am
  By: richard1313

I am having the same problem and tried all of the above. Still I can not get the posted e-mail sent from the form.
The DAT file is populated and the auto-responce comes to me... The auto responce though is coming to the same address as the form is being sent to...is this a concern.



Reply To This Topic

Subject
Message  
Username
Password
Due to unrelated post's, you must have an
account to post a message. To Sign Up click here.




Copyright 2000-2010 Seth M. Knorr,
BizMailForm.com Forms Processor, All Rights Reserved