Home

   Home

   Download


Help

   FAQ

   Installation

   Message Board

   Importing Data File
   Into GoldMine
   Into Act


Other

   Testimonies

   Custom Programming

   PHP Version


Other Favorites

   Hire a clean comedian

   Bible Search Engine

   Bible in a Year

   Parallel Bible

   The Richer Life










 





[ Message Board Home ]    [ Post Reply ]    [ Log In ]    [ Sign Up ]



  Subject: Internal Server Error 500
  Posted: 01/29/2004 at 3:06:00 pm
  By: ronny

Firstly, great script and thanks for keeping it free.

I am having trouble and keep getting the internal server error 500. I am using a windows server, however when I went to edit the windows version (bizmail.pl) i found there was no option for using sendmail. My form is located at www.jeron.co.uk/hasmo/feedback.htm and my script is located at www.jeron.co.uk/cgi-bin/bizmail.cgi I reverted back to the normail script in hope of getting the sendmail function working.



  Subject: Re: Internal Server Error 500
  Posted: 01/30/2004 at 6:08:21 am
  By: Seth Knorr

1. If the current version of the script you are running is the Linux one, then your problem is not sendmail. That will not give you an internal error unless you post to the script. So that mean something else has to be wrong. because when you go directly to the script it says internal error.

2. The windows version only alows you to send posts through SMTP. This is generaly the default.

3. If you have a windows server and need sendmail download:

sendmail_bmf9.zip

This will contain only bizmail.pl and just configure this and use it instead of the bizmail.pl that was in
the regular zip file.

Seth



  Subject: Re: Internal Server Error 500
  Posted: 01/30/2004 at 7:41:06 am
  By: ronny

Unfortunatly i am stil getting the internal error. I contacted my hosting company and they said they found the following in my error log:

line 185, near "$value =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack(""
(Might be a runaway multi-line "" string starting on line 169)
(Missing semicolon on previous line?)
String found where operator expected at bizmail.cgi line 185, near "C", hex($1))/eg; " Out of memory!

Any ideas?

Thanks alot

Ronny



  Subject: Re: Internal Server Error 500
  Posted: 01/30/2004 at 5:39:21 pm
  By: Seth Knorr

Yeah that looks rough, I think it could be a server time out isue.

Are you running Windows or Linux?

Let me know which one, that may pin point the problem more.

Seth



  Subject: Re: Internal Server Error 500
  Posted: 01/31/2004 at 2:50:44 am
  By: ronny

windows



  Subject: Re: Internal Server Error 500
  Posted: 02/03/2004 at 2:04:54 pm
  By: ronny

I have contacted my hosting company and they have informed me that my site is hosted on a lynx red hat server.

Any ideas? this is the error message i recieve:

The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:


String found where operator expected at C:\webspace\reseller\web00691\hasmonean.co.uk\www\cgi-bin\hasmo_feedback.cgi line 182, near "$value =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack(""
(Might be a runaway multi-line "" string starting on line 166)
(Missing semicolon on previous line?)
Out of memory!




  Subject: Re: Internal Server Error 500
  Posted: 02/03/2004 at 2:11:41 pm
  By: Seth Knorr

I have made a couple of changes since you posted to optimize the script toward different OS's. you may want to download the script again and try re-configuring it. That may work, if not let me know what error you get, and I will check into that.

Seth



Reply To This Topic

Subject
Message  
Username
Password
Due to unrelated post's, you must have an
account to post a message. To Sign Up click here.




Copyright 2000-2010 Seth M. Knorr,
BizMailForm.com Forms Processor, All Rights Reserved