Home

   Home

   Download


Help

   FAQ

   Installation

   Message Board

   Importing Data File
   Into GoldMine
   Into Act


Other

   Testimonies

   Custom Programming

   PHP Version


Other Favorites

   Hire a clean comedian

   Bible Search Engine

   Bible in a Year

   Parallel Bible

   The Richer Life










 





[ Message Board Home ]    [ Post Reply ]    [ Log In ]    [ Sign Up ]



  Subject: Attachments
  Posted: 07/26/2004 at 11:26:34 am
  By: ianclarke

Dear Seth,

I'm having trouble getting attachments to work.

1. The script works fine when I don't require an attachment.

2. When I make the following changes:

#----- F I L E A T T A C H M E N T -----#

## $send_attachement specifys if you want to send an attachment with the auto response. ##
## Set $send_attachement = "1"; to send attachment with autoresponse ##
## Set $send_attachement = "2"; to not send attachment with autoresponse ##

$send_attachement = "1";

## IF USING A FILE ATTACHMENT YOU MUST CONFIGURE THE BELOW THREE VARIABLES ##

$attachment_nm = "mym.pdf"; ## file name of attachement ##

$att_path = "http://www.mydomain.co.uk/brochures/courses/mym.pdf"; ## Path to file attachement##

$att_format = ".pdf"; ## File attachement extension, or file type (basicaly .exstension ) ##

I get an "Internal Server Error".

I'm using Version 2.

I've tried $att_format = "pdf"; instead of $att_format = ".pdf";

I've tried $att_path = "http://www.mydomain.co.uk/brochures/courses/"; instead of $att_path = "http://www.mydomain.co.uk/brochures/courses/mym.pdf";

Any suggestions?

Many thanks in anticipation.

Best wishes

Ian



  Subject: Re: Attachments
  Posted: 07/26/2004 at 12:31:32 pm
  By: Seth Knorr

Ok firstly, the $att_path, needs to be the abosolute server path to the attachment. The URL path will not work.

so for instance it should look something like:

$att_path = "/home/user/web/brochures/courses/";

It should also not contain the file name.

Seth



  Subject: Re: Attachments
  Posted: 07/26/2004 at 2:32:41 pm
  By: ianclarke

Dear Seth,

Many thanks - I didn't realise it had to be the absolute path. The PDF attachment is now being sent with the html.mes file but it is being corrupted so cannot be opened in Adobe Reader. I've tried $att_format = "pdf"; and $att_format = ".pdf"; but the file is corrupted which ever I use.
Any suggestions?

Many thanks again for your help.

Best wishes

Ian



  Subject: Re: Attachments
  Posted: 07/26/2004 at 2:39:59 pm
  By: ianclarke

Dear Seth,

Have just read "pdf corruption" but I don't think it has helped. The PDF file is on my server and opens OK in my browser. Would it help if I upgrade to Version 2.1.2? I have downloaded it. Can I upgrade by simply uploading bizmail.cgi or will I need to upload other files as well?

Many thanks

Ian



  Subject: Re: Attachments
  Posted: 07/26/2004 at 2:47:21 pm
  By: Seth Knorr

You will need to re-upload all the scripts in version 2.1.2. You will want to anyway because there are new scripts and bug fixes on the latest zip.

Seth



  Subject: Re: Attachments
  Posted: 07/26/2004 at 3:01:15 pm
  By: ianclarke

Dwear Seth,

Thanks - is it likely to cure the PDF corruption problem?

Many thanks

Ian



  Subject: Re: Attachments
  Posted: 07/26/2004 at 4:15:53 pm
  By: Seth Knorr

yes,

Seth



  Subject: Re: Attachments
  Posted: 07/29/2004 at 9:30:48 am
  By: ianclarke

Dear Seth,

The upgrade works a treat - many thanks.

Best wishes

Ian




Reply To This Topic

Subject
Message  
Username
Password
Due to unrelated post's, you must have an
account to post a message. To Sign Up click here.




Copyright 2000-2010 Seth M. Knorr,
BizMailForm.com Forms Processor, All Rights Reserved